Toshiba T1000XE

Resources

Wiki
PC Museum

Please also check the successor Toshiba T1200XE.

Power

The regular power supply is 12V DC attached to the side of the laptop. This power is used to charge the battery. Toshiba will refuse to work even with the power supply if the battery is not charged. As all batteries will be dead at this age, the only way is to attach the power supply instead of the battery. There are 6 battery cells, so the battery voltage should be 9V.

It looks like 0.6A was the maximum current observed, so in case a regular power supply was to be connected, with a bit of the margin, 0.6-1A (6-9W) DC supply should be enough.

Video

The integrated display is monochrome CGA with 4 shades of gray (or actually blue).

Internals

16 thoughts on “Toshiba T1000XE

  1. So someone does actually has a working T1000XE. I’ve had a few of these fall into my hands and all of them had power issues dispite replacing all the leaking power capacitors. I noticed that you have applied 9V to the battery terminals instead of the 7.2V ? I’ve managed to get one of these booting using this method but when the message about the cmos settings error shows on the screen, the system just automatically powers off. This happens with the display and hard drive disconnected also, so the problem appears to be power related.

    Like

    1. Hey arnold,
      my T1000XE works also. Just the backlight doesn’t do the job :/ Still searching for the error… the Poti works fine, but no voltage can be measured there. So I assume the problem is already somewhere “above”. Do you have a schematic?
      For your problem:
      The automatically power off comes from the not correctly installed HDD caddy. If no HDD connected the is missing a signal at the 2pin-LOCK. Important: It is not important if any HDD is installed. The important thing is that the caddy is correctly installed and the LOCK signal is there.

      Like

      1. Thomas, Thank you very much for the tip about the HDD and the LOCK. I wondered what that 2 pin plug was for. Anyway, I finally did get it booting to DOS prompt but as per-usual with all this OLDCRAP something else decides to fail. The keyboard! took it apart and many traces were worn away. That’s an eay fix with some silver paint or a replacement keyboard though. Just happy to see it working now (without a backlight) just like yours. I may try adding a LED backlight and remove the inverter board as this causes all sorts of power issues.

        Like

  2. Hello, I have a problem. My 1000XE starts up and passes the bios check, but it won’t boot in DOS. First I thought it was a matter of loading MS-DOS in the laptop, but the system software is on a ROM. I haven’t opened the laptop yet. Some suggestions what to look for, like capacitors? There is a small Cmos battery inside, no problem to replace, but also a sub battery. Do I have to replace it also?

    Like

      1. @ Pawel Pieczul, Forgive me, but I mentioned the MS-DOS (3.30) is on a Rom, Can you explain why I have to check the Bios settings? Do you have experience with the Toshiba T1000XE? I cannot change settings without loading the ROM first.

        Like

      2. You are right, this is what the manual says, but I have not noticed that or just tried to boot from floppy. I would need to pull the machine from the storage and see. This is very interesting.

        Like

      3. I removed the keyboard and there are two batteries underneath. 1) Cmos battery 1.2v at 50 mah 2) Sub battery ( also called stand-by battery) 6v at 120mah. Both are dead. I wonder if the DOS rom gets its power from the sub battery only. If so, the problem is located. To solve this problem, I can A) replace the sub battery B) bypass the Rom by loading MS-Dos from a floppy ????

        Like

      4. MS-DOS 3.30 is kept on the Toshiba rom chip TC534000, which is under the Keyboard. Can anyone confirm this Dos Rom is powered by the 1.2v Cmos battery?

        By the way the wires to the sub battery showed me around 12v, so there is power from the motherboard. This battery doesn’t need to be replaced if you keep the laptop powered on with the adapter. I cut the wires.

        Like

      5. Eureka, problem solved. The MS dos Rom only gets activated with a correct HDD installed. A CF card adapter is not accepted. I got it all working. I replaced the old battery with a 7.2v 1800mah NI-CD battery. The new HDD is a Conner 126MB 26 pin. The power adapter functions ok and charges the battery ( although it gets pretty warm) and gives me more than 2 hours runtime. The display is clear. Next project: replacing the belt of the external FDD, which could be finding a needle in a haystack. Does someone know the dimensions or replacement?

        Like

      6. Sorry, but my cheering was too soon. Although I get in the “Bios” it doesn’t show the HDD. The diagnostic software aborts the test on the HDD with error code 805103. The HDD innitialy spins, but that’s it. Checked the HDD via my Windows 10 laptop. It’s apperaring, but needs to be innitialized ( maybe a driver error). To be short, I don’t know the error, or the HDD is bad after all.

        Like

      7. Hey Richard,

        is it possible with the booted DOS to format any partition or set a new one with “fdisk”?
        I know from other Toshiba laptops (e.g. T2000SXe) that specific HDDs are hard-coded in the BIOS, which means it checks for very specific ones… if there is none of these, it wont recognize any HDD.

        For me the laptop works also without any HDD, but important: the HDD caddy needs to be installed properly…. then at least it will boot into DOS 3.3 from ROM and recognize it as “C:”

        Like

      8. I know there were not alot of international standards those times. Every manufacturer had his own idea to setup a computer. After many trials and more errors, I come to the conclusion this laptop only can hold a conner 20/40MB HDD. Unfortunately these HDD’s are getting very rare ( read expensive). It doesn’t accept a modern kind of storage and even a different brand low capacity IDE HDD in FAT16 is not accepted. Strangely, I swapped the broken 20MB for a Conner 120MB. It won’t recognize this HDD, but this is only one which allows to boot into “C”. The caddy without a HDD won’t even start up. The caddy without correct HDD won’t pass the memory count. One question left, I checked the 120MB HDD via my usb-adapter, Windows 10 Diskpart shows only 512B. which is the boot sector. Any idea where the rest of the 120mb is?

        Like

  3. Just an update with my progress on one of these laptops.
    I’ve later found out that the laptop will power off just before posting if the hard disk caddy is not installed.
    The locking clips activate a microswitch which the computer detects and refuses to power. Also 9V is the maximum voltage that can be used on the battery clips, any other voltage higher and the laptop will not power on.
    The LCD uses a flexible backlight sheet which can be removed and replaced easily. The inverter circuit fails on these LCD’s and causes the laptop to power off within 2 seconds of power be applied. Disconnecting the LCD backlight inverter cable from the inverter board fixes the power off issue, but of course, the display then has no backlight but is still viewable.

    Like

Leave a Reply to Thomas Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s